WordPress Internet Explorer Tarayıcı Uyarısı

WordPress Internet Explorer Tarayıcı Uyarısı



’ın web sitelerinde birçok hata vermesi nedeniyle artık kullanımı eskiye oranla azalmaya başladı. Kullanıcılar artık farklı tarayıcılara yönelmeye başladı. Fakat birçok kullanıcı hala kullanmakta ve girdikleri web sitelerinde birçok hata ile karşılaşabilmektedirler. Özellikle de ’ın eski bir versiyonuna sahipseler web sitesini görüntüleyebilmek tam bir işkence oluyor.

tabanlı sitelerimizde yaptığımız değişiklikler birçok tarayıcıya uyumlu olsa da Internet Explorer bazı düzenlemelerimizi hata olarak algılayabiliyor ve sayfada kayma, tasarım bozuklukları gibi sorunlara neden olabiliyor. Bu sorunu bir nebze de olsa azaltabilmek için siteye girenlerin tarayıcı tipini ve versiyonunu alıp Internet Explorer kullanmaları halinde onlara bir uyarı sunabiliriz.

Bunun için header.php dosyamıza küçük bir kod eklememiz yeterli olacaktır. Aşağıdaki kodu eklediğimizde, sitemize giren eğer Internet Explorer kullanıyorsa ona Internet Explorer kullandığını, tarayıcısını güncellemesi gerektiği şeklinde bir uyarı verebiliriz.

 

<?php if ( is_IE() ) { 
	$browserInfo = php_browser_info();
	$browser = $browserInfo[browser];
	$version = $browserInfo[version];

	echo '<div class="browser-notification">'.$browser.' '.$version.' versiyonunu 
kullanıyorsunuz. Siteyi daha iyi görüntüleyebilmek için lütfen tarayıcınızı güncelleyiniz.</div>';
}; ?>



Yazıyı Beğendiyseniz Bültenimize Abone Olabilirsiniz!


Gelen Arama Sonuçları:explorer taray?c? olarak ekleme (32)

Devamını oku:
Avea iPhone5’i 14 Aralık’ta Satışa Sunuyor

Mobil gsm operatörlerinden Avea, Apple'ın son ürünü olan iPhone5'i 14...

Kapat